Service outage on Credit Check solution

Incident Report for Subaio

Resolved

This incident has been resolved.
Posted May 13, 2026 - 11:41 CEST

Investigating

We’re experiencing a service outage on the Credit Check solution.

The error results in budgets not being able to be completed.

Our team is currently working on restoring normal operations.

Next update within the hour.

We apologize for any disturbance.
Posted May 13, 2026 - 11:08 CEST
This incident affected: Credit Check Services (Budget API).