Outage on MitID

Incident Report for Subaio

Resolved

Incident was reported resolved 11:42
Posted Feb 27, 2026 - 13:14 CET

Investigating

MitID is currently unavailable.

Incident was reported by Signaturgruppen at 10:18 - https://www.signaturgruppen.dk/driftsstatus
Posted Feb 27, 2026 - 11:07 CET
This incident affected: Credit Check Services (MitID).