Elevated error rates on account fetch calls for PSD2 provider 'Nordea'

Incident Report for Subaio

Resolved

This incident has been resolved.
Posted Mar 05, 2026 - 09:34 CET

Investigating

We are seeing elevated error rates on account fetch calls for PSD2 provider 'Nordea' since 06:30 this morning, 05/03.

This is impacting Credit Check.

Nordea is aware of the issue and is currently looking into the problem.
Posted Mar 05, 2026 - 09:24 CET
This incident affected: Credit Check Services (Bank Integrations).