Elevated error rates on various PSD2 calls towards all BEC based providers

Incident Report for Subaio

Resolved

This incident has been resolved.

BEC's hosting provider reported that the issue was fixed 23:05
Posted Dec 16, 2025 - 09:28 CET

Investigating

We are experiencing elevated error rates on various PSD2 calls towards all BEC based providers, in relation to the Credit Check Service.

The errors began ~18:00, 15/12/2025.

The issue is caused by an outage at BEC's hosting provider.
Posted Dec 15, 2025 - 21:42 CET
This incident affected: Credit Check Services (Bank Integrations).