A fix has been implemented and we are monitoring the results.
Posted Feb 27, 2026 - 10:35 CET
Investigating
We are experiencing elevated error rates on account fetch calls towards provider Nordea.
The incident is affecting both the Credit Check's ability to fetch data when Nordea is selected as well as logins to the Subscription management feature.
Posted Feb 27, 2026 - 09:48 CET
This incident affected: Credit Check Services (Bank Integrations).