Elevated error rates on account fetch calls (PSD2) towards provider Nordea

Incident Report for Subaio

Resolved

This incident has been resolved.
Posted Sep 14, 2026 - 13:38 CEST

Investigating

We are seeing elevated error rates on PSD2 login/account fetch calls towards provider DK_Nordea, in relation to the Credit Check Service.

The errors began around 12.
Posted Sep 14, 2026 - 12:33 CEST
This incident affected: Credit Check Services (Bank Integrations).