Elevated error rates on account fetch calls (PSD2) towards Netcompany Banking Services banks

Incident Report for Subaio

Resolved

This incident has been resolved.
Posted Jun 30, 2026 - 11:25 CEST

Investigating

We are seeing elevated error rates on PSD2 account fetch calls made towards Netcompany Banking Services banks, in relation to the Credit Check Service.

The errors are assumed to have begun ~08:58.

Netcompany Banking Services is currently troubleshooting the issue.
Posted Jun 30, 2026 - 09:53 CEST
This incident affected: Credit Check Services (Bank Integrations).