Elevated error rates observed on PSD2 calls towards BEC banks

Incident Report for Subaio

Resolved

BEC reports that the incident has been resolved
Posted Aug 31, 2026 - 16:36 CEST

Identified

We are seeing elevated error rates on PSD2 calls towards BEC banks since this morning.

BEC is looking into the problem.
Posted Aug 31, 2026 - 10:51 CEST
This incident affected: Credit Check Services (Bank Integrations).