Elevated error rates on account fetch calls (PSD2) towards Bankdata banks

Incident Report for Subaio

Resolved

This incident has been resolved.

Latest error logged 12:50.
Posted Aug 24, 2026 - 13:39 CEST

Investigating

We are seeing elevated error rates on PSD2 account fetch calls towards Bankdata banks in relation to the Credit Check Service.

The errors were first observed around 10:30 today, 24/08.

We are monitoring the issue, but we've seen that several of the underlying banks report of current login issues.
Posted Aug 24, 2026 - 12:47 CEST
This incident affected: Credit Check Services (Bank Integrations).