Elevated error rates on account fetch calls (PSD2) towards BEC provider banks

Incident Report for Subaio

Resolved

This incident has been resolved.
Posted Sep 18, 2026 - 13:37 CEST

Investigating

We are seeing elevated error rates on PSD2 account fetch calls towards BEC provider banks in relation to the Credit Check Service.

The errors were first observed around 12:00.
Posted Sep 18, 2026 - 12:47 CEST
This incident affected: Credit Check Services (Bank Integrations).